最新消息:关注【太平洋学习网】微信公众号,可以获取全套资料,【全套Java基础27天】【JavaEE就业视频4个月】【Android就业视频4个月】

Error:Execution failed for task ':app:processDebugManifest'

Android 太平洋学习网 浏览 评论

在android app中运行的时候,当出现如下android.support.VERSION冲突异常,具体如下:

Error:Execution failed for task ':app:processDebugManifest'.

> Manifest merger failed : Attribute meta-data#android.support.VERSION@value value=(25.3.1) from [com.android.support:appcompat-v7:25.3.1] AndroidManifest.xml:27:9-31

is also present at [com.android.support:support-v4:26.0.0-alpha1] AndroidManifest.xml:27:9-38 value=(26.0.0-alpha1).

Suggestion: add 'tools:replace="android:value"' to <meta-data> element at AndroidManifest.xml:25:5-27:34 to override.


异常解决:

报这样的异常是因为我们的项目build.gradle里面用的是v7组件:compile 'com.android.support:appcompat-v7:25.3.1',而build.gradle里面却还有一个v4相关的组件,所以形成了冲突,这个时候只需要找到compile "com.android.support:support-v4:+",将它删除或注释掉就可以了。

来源网站:太平洋学习网,转载请注明出处:http://www.tpyyes.com/a/android/2018/0105/465.html

    与本文相关的文章

    发表我的评论
    取消评论

    表情

    您的回复是我们的动力!

    • 昵称 (必填)

    网友最新评论